PKGBUILD 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # SPDX-License-Identifier: CC0-1.0
  2. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  3. # NOTE: This PKGBUILD does not need to be edited manually.
  4. # The package is normally built automatically by the auto-builder.
  5. # To generate a new package, simply push changes to blacklist.git.
  6. # If ${pkgname}-blacklist.txt is modified, the auto-builder will
  7. # replace $pkgver, $_srcver, and the checksum (updpkgsums),
  8. # build and publish the package, and commit the changes to abslibre.
  9. pkgname=your-freedom
  10. pkgver=20240521
  11. _srcver=65c07f43753523692ca4642b1a285d73a77c1210
  12. pkgrel=1
  13. pkgdesc="This meta-package conflicts with every known non-free Arch package"
  14. arch=(any)
  15. url=https://wiki.parabola.nu/Blacklist
  16. license=(custom:CCPL:zero)
  17. # license=('CCPL:zero') # TODO: NYI
  18. makedepends=(librelib)
  19. install=${pkgname}.install
  20. _srcname=${pkgname}-blacklist-${_srcver}.txt
  21. source=(${_srcname}::https://git.parabola.nu/blacklist.git/plain/blacklist.txt?id=${_srcver})
  22. sha256sums=('07f9c3202f65d57b659958ddc6c67805235eedd4ce74c445f248dd9d16b612c6')
  23. package()
  24. {
  25. # collect blacklisted package names as pacman conflicts,
  26. # also to be excluded by the repo importer, and rejected by libremakepkg
  27. conflicts=( $( libreblacklist normalize < ${_srcname} | \
  28. cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
  29. install -Dm644 ${_srcname} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
  30. }