123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899 |
- # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
- _target=x86_64-pc-linux-gnu
- pkgname=$_target-gcc
- _pkgver=9.2.0
- #_snapshot=8-20180824
- pkgver=$_pkgver${_snapshot/*-/+}
- _islver=0.21
- pkgrel=1
- pkgdesc='The GNU Compiler Collection - cross compiler for x86_64 target'
- arch=(i686 armv7h)
- url='http://gcc.gnu.org/'
- license=(GPL LGPL FDL)
- depends=($_target-binutils libmpc zlib)
- makedepends=(gmp mpfr)
- options=(!emptydirs !strip)
- source=(https://gcc.gnu.org/pub/gcc/releases/gcc-$_pkgver/gcc-$_pkgver.tar.xz{,.sig}
- #https://gcc.gnu.org/pub/gcc/snapshots/$_snapshot/gcc-$_snapshot.tar.xz
- http://isl.gforge.inria.fr/isl-$_islver.tar.bz2)
- sha512sums=('b6134df027e734cee5395afd739fcfa4ea319a6017d662e54e89df927dea19d3fff7a6e35d676685383034e3db01c9d0b653f63574c274eeb15a2cb0bc7a1f28'
- 'SKIP'
- 'a12dff52af876aee0fd89a8d09cdc455f35ec46845e154023202392adc164848faf8ee881b59b681b696e27c69fd143a214014db4214db62f9891a1c8365c040')
- validpgpkeys=(33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com>
- if [ -n "$_snapshot" ]; then
- _basedir=gcc-$_snapshot
- else
- _basedir=gcc-$_pkgver
- fi
- prepare() {
- cd $_basedir
- # link isl for in-tree builds
- ln -sf ../isl-$_islver isl
- echo $_pkgver > gcc/BASE-VER
- # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" "$srcdir"/$_basedir/{libiberty,gcc}/configure
- mkdir $srcdir/gcc-build
- }
- build() {
- cd gcc-build
- # using -pipe causes spurious test-suite failures
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS=${CFLAGS/-pipe/}
- CXXFLAGS=${CXXFLAGS/-pipe/}
- $srcdir/$_basedir/configure \
- --target=$_target \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --enable-languages=c,c++ \
- --enable-plugins \
- --enable-shared \
- --disable-decimal-float \
- --disable-libffi \
- --disable-libgomp \
- --disable-libmudflap \
- --disable-libquadmath \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-nls \
- --disable-threads \
- --disable-tls \
- --disable-multilib \
- --with-gnu-as \
- --with-gnu-ld \
- --with-system-zlib \
- --with-gmp \
- --with-mpfr \
- --with-mpc \
- --with-isl \
- --with-libelf \
- --enable-gnu-indirect-function
- make $MAKEFLAGS all-gcc
- }
- package() {
- cd gcc-build
- make DESTDIR="$pkgdir" install-gcc
- # strip target binaries
- find "$pkgdir"/usr/lib/gcc/$_target/ -type f -and \( -name \*.a -or -name \*.o \) -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
- # strip host binaries
- find "$pkgdir"/usr/bin/ "$pkgdir"/usr/lib/gcc/$_target/ -type f -and \( -executable \) -exec strip '{}' \;
- # Remove files that conflict with host gcc package
- rm -r "$pkgdir"/usr/share/man/man7
- rm -r "$pkgdir"/usr/share/info
- }
|