PKGBUILD 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Maintainer (arch): Anatol Pomozov <anatol.pomozov@gmail.com>
  2. # Contributor: Michael Düll <mail@akurei.me> PGP-Key: AAAEE882
  3. # Contributor: TDY <tdy@gmx.com>
  4. # Contributor: Sergio Rubio <rubiojr.ml@gmail.com>
  5. # Contributor: Hannes Rist <cowider@gmail.com>
  6. # Contributor: André Silva <emulatorman@hyperbola.info>
  7. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  8. pkgname=unp
  9. pkgver=2.0~pre7+nmu1
  10. pkgrel=3
  11. pkgrel+=.parabola1
  12. pkgdesc='A script for unpacking a wide variety of archive formats'
  13. pkgdesc+=', without nonfree unace, unarj and unrar recommendation'
  14. arch=(any)
  15. url='https://packages.qa.debian.org/u/unp.html'
  16. license=(GPL)
  17. depends=(perl)
  18. optdepends=(
  19. 'unzip: zip support'
  20. 'bzip2: bzip2 support'
  21. 'p7zip: p7zip support'
  22. 'cpio: cpio support'
  23. 'sharutils: sharutils'
  24. 'cabextract: cab support'
  25. 'rpmextract: rpm support'
  26. )
  27. source=(http://ftp.debian.org/debian/pool/main/u/unp/unp_$pkgver.tar.bz2
  28. libre.patch)
  29. sha1sums=('b91f4cbc4720b3aace147652ac2043cf74668244'
  30. '202375dd1c013c798d0d61ab5c273be8ebe1c546')
  31. prepare() {
  32. cd unp-$pkgver
  33. patch -Np1 -i "$srcdir"/libre.patch
  34. }
  35. build() {
  36. cd unp-$pkgver/po
  37. make
  38. }
  39. package() {
  40. cd unp-$pkgver
  41. install -Dm755 unp "$pkgdir"/usr/bin/unp
  42. install -Dm755 ucat "$pkgdir"/usr/bin/ucat
  43. install -Dm644 debian/unp.1 "$pkgdir"/usr/share/man/man1/unp.1
  44. install -Dm755 bash_completion.d/unp "$pkgdir"/usr/share/bash-completion/completions/unp
  45. cd po
  46. make DESTDIR="$pkgdir" install
  47. }