PKGBUILD 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  2. # Maintainer (arch): Josip Ponjavic <josipponjavic at gmail dot com>
  3. # Contributor: Balló György <ballogyor+arch at gmail dot com>
  4. # Contributor: bill-auger <bill-auger@programmer.net>
  5. # parabola changes and rationale:
  6. # - build without qt5-webengine
  7. # - frozen at commit 79d6d67 - last commit with webkit support
  8. pkgname=signon-ui
  9. pkgver=0.17+20170320
  10. pkgrel=1
  11. pkgrel+=.parabola1
  12. _commit=79d6d67
  13. pkgdesc='UI component responsible for handling the user interactions which can happen during the login process of an online account'
  14. arch=(x86_64)
  15. arch+=(armv7h i686)
  16. url="https://launchpad.net/online-accounts-signon-ui"
  17. license=(GPL)
  18. depends=(libaccounts-qt qt5-webkit signond libnotify)
  19. source=("https://gitlab.com/accounts-sso/signon-ui/repository/archive.tar.gz?ref=$_commit")
  20. sha256sums=('9b1005b51987703d0b2315bebfaa5acbd4f19fbb10dc215bb6dc8d035b5f91a6')
  21. prepare() {
  22. cd signon-ui-*
  23. # Do not install tests
  24. sed -e 's|src \\|src|' -e '/tests/d' -i signon-ui.pro
  25. }
  26. build() {
  27. cd signon-ui-*
  28. qmake-qt5 PREFIX=/usr LIBDIR=/usr/lib
  29. make
  30. }
  31. package() {
  32. cd signon-ui-*
  33. make INSTALL_ROOT="$pkgdir" install
  34. }