PKGBUILD 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  2. # Contributor: Jan de Groot <jgc@archlinux.org>
  3. # Maintainer: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  4. # parabola changes and rationale:
  5. # - removed unace and unrar recommendation
  6. pkgname=file-roller
  7. pkgver=3.40.0
  8. pkgrel=1
  9. pkgrel+=.parabola1
  10. pkgdesc="Create and modify archives"
  11. pkgdesc+=", without nonfree unace and unrar recommendation"
  12. url="https://wiki.gnome.org/Apps/FileRoller"
  13. arch=(x86_64)
  14. arch+=(i686 armv7h)
  15. license=(GPL)
  16. depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
  17. makedepends=(yelp-tools git libnautilus-extension meson appstream-glib)
  18. optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
  19. 'lrzip: lrzip archive support'
  20. 'squashfs-tools: squashfs image support')
  21. groups=(gnome)
  22. _commit=d5cfba5a4e86b2e8118113be410f39fc854b1df7 # tags/3.40.0^0
  23. source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit")
  24. sha256sums=('SKIP')
  25. pkgver() {
  26. cd $pkgname
  27. git describe --tags | sed 's/-/+/g'
  28. }
  29. prepare() {
  30. cd $pkgname
  31. }
  32. build() {
  33. arch-meson $pkgname build
  34. meson compile -C build
  35. }
  36. check() {
  37. meson test -C build --print-errorlogs
  38. }
  39. package() {
  40. DESTDIR="$pkgdir" meson install -C build
  41. }