PKGBUILD 1.2 KB

1234567891011121314151617181920212223242526272829303132333435
  1. # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
  2. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  3. _basekernel=5.4.12-1
  4. pkgname=deepin-anything-module
  5. pkgver=5.0.1
  6. pkgrel=45
  7. pkgrel+=.parabola1.basekernel${_basekernel%-*}
  8. pkgdesc="Deepin Anything file search tool, kernel module for Linux kernel"
  9. pkgdesc+=' (built for the linux-libre kernel package)'
  10. arch=('x86_64')
  11. url="https://github.com/linuxdeepin/deepin-anything"
  12. license=('GPL3')
  13. makedepends=(linux-libre-headers=${_basekernel%-*} libelf)
  14. conflicts=('deepin-anything-arch')
  15. provides=('DEEPIN-ANYTHING-MODULE')
  16. replaces=('deepin-anything-arch')
  17. source=("$pkgname-$pkgver.tar.gz::https://github.com/linuxdeepin/deepin-anything/archive/$pkgver.tar.gz")
  18. sha512sums=('f79b4db917cce2611bd6964d00ae0e162fc500fa7ca76a987145456a9ee81296c776d2b83cf6492a4224c4e4fd95df3ad95a25c1c14d2d4e6865f5bbd639be14')
  19. build() {
  20. cd deepin-anything-$pkgver
  21. make -C kernelmod kdir=/usr/src/linux-libre
  22. }
  23. package() {
  24. depends=(linux-libre=${_basekernel%-*})
  25. cd deepin-anything-$pkgver
  26. local extradir=/usr/lib/modules/$(</usr/src/linux-libre/version)/extramodules
  27. install -Dt "$pkgdir$extradir" -m644 kernelmod/*.ko
  28. find "$pkgdir" -name '*.ko' -exec xz {} +
  29. }