123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107 |
- # Maintainer (arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
- # Maintainer (arch): Giancarlo Razzolini <grazzolini@archlinux.org>
- # Contributor: Dale Blount <dale@archlinux.org>
- # Contributor: Gregor Ibic <gregor.ibic@intelicom.si>
- # Contributor: Gaetan Bisson <bisson@archlinux.org>
- # Contributor: André Silva <emulatorman@hyperbola.info>
- # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
- # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
- # Contributor: Andreas Grapentin <andreas@grapentin.org>
- pkgname=clamav
- pkgver=0.103.3
- pkgrel=1
- pkgrel+=.parabola1
- pkgdesc='Anti-virus toolkit for Unix'
- pkgdesc+=', without nonfree decompression engine for RAR archives'
- url='https://www.clamav.net/'
- license=('GPL')
- arch=('x86_64')
- arch+=('i686' 'armv7h')
- depends=('bzip2' 'libltdl' 'libxml2' 'curl' 'systemd-libs' 'pcre2' 'json-c' 'libmspack')
- makedepends=('libmilter' 'systemd')
- checkdepends=('check')
- backup=('etc/clamav/clamd.conf'
- 'etc/clamav/freshclam.conf'
- 'etc/clamav/clamav-milter.conf'
- 'etc/logrotate.d/clamav')
- provides=(libclamav.so libclamunrar.so libclamunrar_iface.so)
- source=(https://www.clamav.net/downloads/production/${pkgname}-${pkgver}.tar.gz{,.sig}
- clamav.logrotate
- clamav.tmpfiles
- clamav.sysusers)
- sha512sums=('c2ee24a6f63735c064140aa5baa347d51e8240b2f7eced3480d05435202aedd481fa7057fd40ecbc2e93a62fe8b0cefb574d8accdf9acede643ffbe0d396686f'
- 'SKIP'
- '9cb168c1c16bb43c99900d7ef34456e3f3b593d4d1943c875a0306bc86fd3872cb78e9e1413dcba93579e01b96d466c9eea1975e24190193663b7986c4525d48'
- 'c5443634399bd87fe0d0192518538ffdb7296a8437b5b0160a0fbd58696b01285de3237e3feb552c0095c49e576832dec2e2b2107eef2be42424ed7edd13cd19'
- 'b984836f6c34d97b90d81fa5d17361a2e3f8c0cc709e3350a4d25cf088dc04f7bf2504359980c8be489c96b1b8798c60e6da533069d3378d49d4f50f929a2c90')
- validpgpkeys=('E34DB95B374B31570496CD3F609B024F2B3EDD07') # Talos (Talos, Cisco Systems Inc.) <research@sourcefire.com>
- prepare() {
- cd ${pkgname}-${pkgver}
- msg2 "remove nonfree unRAR utility files from the source"
- rm -rv libclamunrar
- rm -v COPYING.unrar
-
- sed -E 's|^(Example)$|#\1|' -i etc/{clamd,freshclam,clamav-milter}.conf.sample
- sed -E 's|#(User) .+|\1 clamav|' -i etc/{clamd,freshclam,clamav-milter}.conf.sample
- sed -E 's|#(LogFile) .+|\1 /var/log/clamav/clamd.log|' -i etc/clamd.conf.sample
- sed -E 's|#(LogTime) .+|\1 yes|' -i etc/clamd.conf.sample etc/clamav-milter.conf.sample
- sed -E 's|#(PidFile) .+|\1 /run/clamav/clamd.pid|' -i etc/clamd.conf.sample
- sed -E 's|#(TemporaryDirectory) .+|\1 /tmp|' -i etc/{clamd,clamav-milter}.conf.sample
- sed -E 's|#(LocalSocket) .+|\1 /run/clamav/clamd.ctl|' -i etc/clamd.conf.sample
- sed -E 's|#(UpdateLogFile) .+|\1 /var/log/clamav/freshclam.log|' -i etc/freshclam.conf.sample
- sed -E 's|#(DatabaseMirror) .+|\1 database.clamav.net|' -i etc/freshclam.conf.sample
- sed -E 's|#(NotifyClamd) .+|\1 /etc/clamav/clamd.conf|' -i etc/freshclam.conf.sample
- sed -E 's|#(PidFile) .+|\1 /run/clamav/freshclam.pid|' -i etc/freshclam.conf.sample
- sed -E 's|#(LogFile) .+|\1 /var/log/clamav/clamav-milter.log|' -i etc/clamav-milter.conf.sample
- sed -E 's|#(PidFile) .+|\1 /run/clamav/clamav-milter.pid|' -i etc/clamav-milter.conf.sample
- sed -E "s|(\\[Unit\\])|\\1\\nWants=network-online.target\\nAfter=network-online.target|" -i freshclam/clamav-freshclam.service.in
- autoreconf -fiv
- }
- build() {
- cd ${pkgname}-${pkgver}
- # --disable-zlib-vcheck because the configure script thinks that
- # zlib 1.2.11 is older than 1.2.2
- # --enable-llvm=no:
- # workaround for database update issues
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/clamav \
- --with-dbdir=/var/lib/clamav \
- --with-user=clamav \
- --with-group=clamav \
- --with-system-libmspack \
- --disable-rpath \
- --disable-clamav \
- --disable-llvm \
- --enable-zlib-vcheck \
- --enable-milter \
- --enable-clamdtop \
- --disable-unrar \
- --enable-llvm=no
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
- }
- check() {
- cd ${pkgname}-${pkgver}
- make check
- }
- package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/etc/clamav/freshclam.conf{.sample,}
- mv "${pkgdir}"/etc/clamav/clamd.conf{.sample,}
- mv "${pkgdir}"/etc/clamav/clamav-milter.conf{.sample,}
- install -Dm 644 ../clamav.sysusers "${pkgdir}"/usr/lib/sysusers.d/clamav.conf
- install -Dm 644 ../clamav.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/clamav.conf
- install -Dm 644 ../clamav.logrotate "${pkgdir}"/etc/logrotate.d/clamav
- }
|