1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465 |
- # Maintainer: David P. <megver83@parabola.nu>
- _target=arm-linux-gnueabi
- pkgname=$_target-binutils
- pkgver=2.39
- pkgrel=1
- pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM GNU EABI little-endian target'
- arch=(x86_64 i686 armv7h)
- url='https://www.gnu.org/software/binutils/'
- license=(GPL)
- depends=(zlib libelf)
- source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
- sha512sums=('faa592dd48fc715901ad704ac96dbd34b1792c51e77c7a92a387964b0700703c74be07de45cc4751945c8c0674368c73dc17bbc563d1d2cd235b5ebd8c6e7efb'
- 'SKIP')
- validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
- prepare() {
- cd binutils-$pkgver
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
- }
- build() {
- cd binutils-$pkgver
- if [ "${CARCH}" != "i686" ]; then
- # enabling gold linker at i686 makes the install fail
- enable_gold='--enable-gold'
- fi
- ./configure --target=$_target \
- --with-sysroot=/usr/$_target \
- --prefix=/usr \
- --disable-multilib \
- --with-gnu-as \
- --with-gnu-ld \
- --disable-nls \
- --enable-ld=default \
- $enable_gold \
- --enable-plugins \
- --enable-deterministic-archives
- make
- }
- check() {
- cd binutils-$pkgver
- # unset LDFLAGS as testsuite makes assumptions about which ones are active
- # do not abort on errors - manually check log files
- make LDFLAGS="" -k check || true
- }
- package() {
- cd binutils-$pkgver
- make DESTDIR="$pkgdir" install
- # Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
- rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
- # Remove info documents that conflict with host version
- rm -r "$pkgdir"/usr/share/info
- }
|