PKGBUILD 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor: mortzu <me@mortzu.de>
  3. # Contributor: fnord0 <fnord0@riseup.net>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # Contributor: Márcio Silva <coadde@hyperbola.info>
  6. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. # parabola changes and rationale:
  8. # - no significant change - re-package for linux-libre
  9. # - pin to kernel versions
  10. # build order:
  11. # acpi_call-dkms <- acpi_call-lts
  12. # acpi_call
  13. # linux-libre-lts-headers <- acpi_call-lts
  14. # tp_smapi-lts
  15. # linux-libre-headers <- acpi_call
  16. # tp_smapi
  17. #
  18. # NOTE: It is normally not necessary to edit any of these PKGBUILDs.
  19. # These packages may be built as a batch, with the helper script:
  20. # 'scripts/package-all-acpi_call-tp_smapi'
  21. # Simply edit 'KERNEL_VER' and/or 'KERNEL_LTS_VER' in the helper script.
  22. # It will build any or all of the above packages,
  23. # but only those for which the PKGBUILD '_basekernel' differs,
  24. # update '_basekernel', and commit the changes to VCS, if successful.
  25. _basekernel=6.6.14
  26. pkgname=acpi_call-lts
  27. pkgver=1.2.2
  28. pkgrel=11
  29. pkgrel+=.parabola1.basekernel${_basekernel}
  30. pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call'
  31. pkgdesc+=" (for 'linux-libre-lts')"
  32. url='https://github.com/mkottman/acpi_call'
  33. arch=('x86_64')
  34. arch+=('armv7h' 'i686')
  35. license=('GPL')
  36. makedepends=(linux-libre-lts-headers=${_basekernel} acpi_call-dkms=$pkgver libelf)
  37. conflicts=('acpi_call-dkms')
  38. provides=('acpi_call')
  39. build() {
  40. _kernver=$(</usr/src/linux-libre-lts/version)
  41. fakeroot dkms build --dkmstree "$srcdir" -m acpi_call/$pkgver -k $_kernver
  42. }
  43. package() {
  44. depends=(linux-libre-lts=${_basekernel})
  45. _kernver=$(</usr/src/linux-libre-lts/version)
  46. install -Dt "$pkgdir/usr/lib/modules/$_kernver/extramodules" -m0644 \
  47. acpi_call/${pkgver}/$_kernver/$CARCH/module/*
  48. # compress each module individually
  49. find "$pkgdir" -name '*.ko' -exec xz -T1 {} +
  50. echo acpi_call | install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/$pkgname.conf"
  51. mkdir -p "$pkgdir/usr/share"
  52. cp -a /usr/share/acpi_call "$pkgdir/usr/share/$pkgname"
  53. }