PKGBUILD 785 B

123456789101112131415161718192021222324
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. # Maintainer (Artix): artoo <artoo@artixlinux.org>
  3. pkgname=subversion-openrc
  4. pkgver=20210505
  5. pkgrel=2
  6. pkgdesc="OpenRC svnserve init script"
  7. arch=('any')
  8. url="https://gitea.artixlinux.org/artixlinux/packages-openrc"
  9. license=('GPL2')
  10. groups=('openrc-world')
  11. provides=('init-subversion')
  12. conflicts=('init-subversion')
  13. backup=('etc/conf.d/svnserve')
  14. source=("svnserve".{confd,initd})
  15. sha256sums=('b69b09112f2aefe88cb5e84ae35f7f365c72758ede7edadf245acf6a9f266da6'
  16. '9725301066a9ffcadd2391834a1e1f5205d77693e9cc55d875f77b9ae125bcb8')
  17. package() {
  18. depends=('subversion' 'openrc')
  19. install -Dm755 "$srcdir"/svnserve.initd "$pkgdir"/etc/init.d/svnserve
  20. install -Dm644 "$srcdir"/svnserve.confd "$pkgdir"/etc/conf.d/svnserve
  21. }