ipe.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. #!/bin/bash
  2. # Slackware build script for ipe
  3. # Copyright 2020 Charles Daniels, United States
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220222 bkw: Modified by SlackBuilds.org, BUILD=2:
  23. # - fix build on 15.0 (missing C++ includes).
  24. # - fix libdir (/usr/lib => /usr/lib64 on x86_64).
  25. # - fix incorrect ipelets path built into the binary (ugh).
  26. # - eliminate some useless docs (install.txt and macos.txt)
  27. # - symlink html docs to doc dir.
  28. cd $(dirname $0) ; CWD=$(pwd)
  29. PRGNAM=ipe
  30. VERSION=${VERSION:-7.2.13}
  31. BUILD=${BUILD:-2}
  32. TAG=${TAG:-_SBo}
  33. PKGTYPE=${PKGTYPE:-tgz}
  34. if [ -z "$ARCH" ]; then
  35. case "$( uname -m )" in
  36. i?86) ARCH=i586 ;;
  37. arm*) ARCH=arm ;;
  38. *) ARCH=$( uname -m ) ;;
  39. esac
  40. fi
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  74. # 20220226 bkw: C++ madness.
  75. sed -i '1i#include <cstdint>' src/include/ipeattributes.h
  76. sed -i '1i#include <cerrno>' src/ipelib/ipeplatform.cpp
  77. sed -i '1i#include <QPainterPath>' src/ipecanvas/ipecanvas_qt.cpp
  78. # 20220226 bkw: some of these paths get baked into the binaries, so
  79. # we don't want $PKG in them during the build.
  80. runmake() {
  81. QT_SELECT=5 \
  82. make -C src \
  83. IPEPREFIX="$1/usr/" \
  84. IPEMANDIR="$1/usr/man/man1" \
  85. IPELETDIR="$1/usr/lib$LIBDIRSUFFIX/ipe/$VERSION/ipelets" \
  86. IPELIBDIR="$1/usr/lib$LIBDIRSUFFIX" \
  87. MOC=moc-qt5 \
  88. $2
  89. }
  90. runmake
  91. runmake $PKG install
  92. strip $PKG/usr/bin/* $PKG/usr/lib*/*.so.*.*.*
  93. gzip -9 $PKG/usr/man/man*/*
  94. # 20220226 bkw: the real documentation is the html, leave it where 'make
  95. # install' put it, but symlink to where it belongs in a Slackware package.
  96. PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
  97. mkdir -p $PKGDOC
  98. ln -s ../../share/$PRGNAM/$VERSION/doc $PKGDOC/html
  99. cp -a gpl.txt news.txt readme.txt $PKGDOC
  100. cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
  101. mkdir -p $PKG/install
  102. cat $CWD/slack-desc > $PKG/install/slack-desc
  103. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  104. cd $PKG
  105. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE