zulu-openjdk11.SlackBuild 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. #!/bin/bash
  2. # Slackware build script for zulu-openjdk11
  3. # Copyright (c) 2018, Sébastien Ballet <slacker6896 at gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=zulu-openjdk11
  24. VERSION=${VERSION:-11.0.14.1}
  25. ZULUVERSION=${ZULUVERSION:-11.54.25}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i686 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  37. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  38. exit 0
  39. fi
  40. TMP=${TMP:-/tmp/SBo}
  41. PKG=${TMP}/package-${PRGNAM}
  42. OUTPUT=${OUTPUT:-/tmp}
  43. if [ "$ARCH" = "i686" ]; then
  44. ZULU_ARCH=i686
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "x86_64" ]; then
  47. ZULU_ARCH=x64
  48. LIBDIRSUFFIX="64"
  49. else
  50. echo "Architecture ${ARCH} is not supported."
  51. exit 1
  52. fi
  53. SRCNAM=zulu${ZULUVERSION}-ca-jdk${VERSION}-linux_$ZULU_ARCH
  54. set -e
  55. rm -rf ${PKG}
  56. mkdir -p ${TMP} ${PKG} ${OUTPUT}
  57. mkdir -p ${PKG}/usr/lib64/
  58. cd ${PKG}/usr/lib64/
  59. tar xvf ${CWD}/${SRCNAM}.tar.gz
  60. mv ${SRCNAM} ${PRGNAM}
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. mkdir -p ${PKG}/etc/profile.d
  68. for SCRIPT in ${PRGNAM}.sh ${PRGNAM}.csh ; do
  69. cat ${CWD}/${SCRIPT} > ${PKG}/etc/profile.d/${SCRIPT}
  70. chmod 755 ${PKG}/etc/profile.d/${SCRIPT}
  71. done
  72. mkdir -p ${PKG}/usr/doc/${PRGNAM}-${VERSION}
  73. # move folder demo/ in documentation directory
  74. #
  75. mv ${PKG}/usr/lib64/${PRGNAM}/demo ${PKG}/usr/doc/${PRGNAM}-${VERSION}
  76. for CFILE in DISCLAIMER Welcome.html readme.txt ; do
  77. mv ${PKG}/usr/lib64/${PRGNAM}/${CFILE} ${PKG}/usr/doc/${PRGNAM}-${VERSION}
  78. done
  79. cat ${CWD}/${PRGNAM}.SlackBuild > ${PKG}/usr/doc/${PRGNAM}-${VERSION}/${PRGNAM}.SlackBuild
  80. mkdir -p ${PKG}/install
  81. cat ${CWD}/slack-desc > ${PKG}/install/slack-desc
  82. cd ${PKG}
  83. /sbin/makepkg -l y -c n ${OUTPUT}/${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.$PKGTYPE