cvsps.SlackBuild 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. #!/bin/bash
  2. # Slackbuild for cvsps
  3. # Written by JK Wood <joshuakwood@gmail.com>
  4. cd $(dirname $0) ; CWD=$(pwd)
  5. PRGNAM=cvsps
  6. VERSION=${VERSION:-2.2b1}
  7. BUILD=${BUILD:-1}
  8. TAG=${TAG:-_SBo}
  9. PKGTYPE=${PKGTYPE:-tgz}
  10. if [ -z "$ARCH" ]; then
  11. case "$( uname -m )" in
  12. i?86) ARCH=i586 ;;
  13. arm*) ARCH=arm ;;
  14. *) ARCH=$( uname -m ) ;;
  15. esac
  16. fi
  17. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  18. # the name of the created package would be, and then exit. This information
  19. # could be useful to other scripts.
  20. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  21. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  22. exit 0
  23. fi
  24. TMP=${TMP:-/tmp/SBo}
  25. PKG=$TMP/package-$PRGNAM
  26. OUTPUT=${OUTPUT:-/tmp}
  27. if [ "$ARCH" = "i586" ]; then
  28. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  29. LIBDIRSUFFIX=""
  30. elif [ "$ARCH" = "i686" ]; then
  31. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  32. LIBDIRSUFFIX=""
  33. elif [ "$ARCH" = "x86_64" ]; then
  34. SLKCFLAGS="-O2 -fPIC"
  35. LIBDIRSUFFIX="64"
  36. else
  37. SLKCFLAGS="-O2"
  38. LIBDIRSUFFIX=""
  39. fi
  40. rm -rf $PKG
  41. mkdir -p $TMP $PKG $OUTPUT
  42. cd $TMP || exit 1
  43. rm -rf $PRGNAM-$VERSION
  44. tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
  45. cd $PRGNAM-$VERSION || exit 1
  46. chown -R root:root .
  47. find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  48. -exec chmod 755 {} \; -o \
  49. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  50. -exec chmod 644 {} \;
  51. CFLAGS="$SLKCFLAGS" \
  52. CXXFLAGS="$SLKCFLAGS" \
  53. PREFIX=/usr \
  54. make || exit 1
  55. mkdir -p $PKG/usr/bin
  56. install cvsps $PKG/usr/bin/
  57. mkdir -p $PKG/usr/man/man1
  58. install -m 644 cvsps.1 $PKG/usr/man/man1/
  59. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  60. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  61. find $PKG/usr/man -type f -exec gzip -9 {} \;
  62. for i in $( find $PKG/usr/man -type l ); do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  63. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  64. cp -a CHANGELOG COPYING README \
  65. $PKG/usr/doc/$PRGNAM-$VERSION
  66. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  67. find $PKG/usr/doc -name "Makefile" -exec rm {} \;
  68. find $PKG/usr/doc -type f -exec chmod 644 {} \;
  69. mkdir -p $PKG/install
  70. cat $CWD/slack-desc > $PKG/install/slack-desc
  71. cd $PKG
  72. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE