ogmtools.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. #!/bin/bash
  2. #################################################################################
  3. # Slackware Package Build Script for OGMtools
  4. # Copyright (c) 2008, Nishant Limbachia (nishant@mnspace.net)
  5. # All rights reserved.
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. # 1. Redistributions of script must retain the above copyright notice,
  9. # this list of conditions and the following disclaimer.
  10. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  11. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  12. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  13. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
  14. # CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
  15. # EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  16. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
  17. # PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
  18. # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
  19. # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  20. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  21. #################################################################################
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=ogmtools
  24. VERSION=${VERSION:-1.5}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -fr $TMP/$PRGNAM-$VERSION $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  63. cd $TMP/$PRGNAM-$VERSION
  64. chown -R root.root .
  65. find -L . \
  66. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  67. -exec chmod 755 {} \; -o \
  68. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  69. -exec chmod 644 {} \;
  70. patch -p1 < $CWD/gcc11.patch
  71. CFLAGS="$SLKCFLAGS" \
  72. CXXFLAGS="$SLKCFLAGS" \
  73. ./configure \
  74. --prefix=/usr \
  75. --libdir=/usr/lib${LIBDIRSUFFIX} \
  76. --exec-prefix=/usr \
  77. --sysconfdir=/etc \
  78. --localstatedir=/var \
  79. --mandir=/usr/man \
  80. --infodir=/usr/info \
  81. --build=$ARCH-slackware-linux
  82. make
  83. make install DESTDIR=$PKG
  84. find $PKG | xargs file | grep -e "executable" -e "shared object"| grep ELF | \
  85. cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  86. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  87. cp -a COPYING ChangeLog INSTALL \
  88. README TODO $PKG/usr/doc/$PRGNAM-$VERSION
  89. ( cd $PKG/usr/man
  90. find . -type f -exec gzip -9 {} \;
  91. for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
  92. )
  93. mkdir -p $PKG/install
  94. cat $CWD/slack-desc > $PKG/install/slack-desc
  95. ### building package
  96. chown -R root.root $PKG
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE