megax.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. #!/bin/bash
  2. # Slackware build script for megax (formerly 'megacc')
  3. # This takes the place of "megacc" in 2018, as it includes also the GUI
  4. # of the program (megax) in addition to megacc.
  5. # Copyright 2017-2020 Petar Petrov slackalaxy@gmail.com
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=megax
  26. VERSION=${VERSION:-10.2.5_1}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. DEBVER=$(echo $VERSION | tr _ -)
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i386 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i386" ] || [ "$ARCH" = "i486" ] || [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
  49. LIBDIRSUFFIX=""
  50. DEBARCH="i386"
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. LIBDIRSUFFIX="64"
  53. DEBARCH="amd64"
  54. else
  55. printf "\n\n$ARCH is not supported... \n"
  56. exit 1
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. mkdir $PRGNAM-$VERSION
  64. cd $PRGNAM-$VERSION
  65. ar p $CWD/${PRGNAM}_${DEBVER}_${DEBARCH}.deb data.tar.xz | tar xJv
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. # Fix path in runmega.sh for x86_64
  73. sed -i "s|/usr/lib/megax|/usr/lib${LIBDIRSUFFIX}/megax|g" usr/lib/$PRGNAM/runmega.sh
  74. # Place things in /usr/lib and just create symlinks later.
  75. # This is what Debian's and RedHat's packages do.
  76. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
  77. cp -a usr/lib/$PRGNAM $PKG/usr/lib${LIBDIRSUFFIX}
  78. # Copy man pages to their proper place.
  79. cp -a usr/local/share/man $PKG/usr
  80. mkdir -p $PKG/usr/bin
  81. cd $PKG/usr/bin
  82. ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM/megacc
  83. ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM/runmega.sh megax
  84. cd -
  85. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  86. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  87. find $PKG/usr/man -type f -exec gzip -9 {} \;
  88. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  89. # Menu entry for MEGA X, use our .desktop file
  90. mkdir -p $PKG/usr/share/{applications,pixmaps}
  91. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  92. cp usr/share/pixmaps/mega.png $PKG/usr/share/pixmaps/megax.png
  93. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  94. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  95. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  96. mkdir -p $PKG/install
  97. cat $CWD/slack-desc > $PKG/install/slack-desc
  98. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  99. cd $PKG
  100. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE