fann.SlackBuild 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. #!/bin/bash
  2. # Slackware build script for fann
  3. # Written by Andrew Conway (ajc AT countingthoughts DOT com)
  4. cd $(dirname $0) ; CWD=$(pwd)
  5. PRGNAM=fann
  6. VERSION=${VERSION:-2.2.0}
  7. BUILD=${BUILD:-1}
  8. TAG=${TAG:-_SBo}
  9. PKGTYPE=${PKGTYPE:-tgz}
  10. SRCNAME=FANN-$VERSION-Source
  11. if [ -z "$ARCH" ]; then
  12. case "$( uname -m )" in
  13. i?86) ARCH=i486 ;;
  14. arm*) ARCH=arm ;;
  15. *) ARCH=$( uname -m ) ;;
  16. esac
  17. fi
  18. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  19. # the name of the created package would be, and then exit. This information
  20. # could be useful to other scripts.
  21. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  22. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  23. exit 0
  24. fi
  25. TMP=${TMP:-/tmp/SBo}
  26. PKG=$TMP/package-$PRGNAM
  27. OUTPUT=${OUTPUT:-/tmp}
  28. if [ "$ARCH" = "i486" ]; then
  29. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  30. LIBDIRSUFFIX=""
  31. elif [ "$ARCH" = "i686" ]; then
  32. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  33. LIBDIRSUFFIX=""
  34. elif [ "$ARCH" = "x86_64" ]; then
  35. SLKCFLAGS="-O2 -fPIC"
  36. LIBDIRSUFFIX="64"
  37. else
  38. SLKCFLAGS="-O2"
  39. LIBDIRSUFFIX=""
  40. fi
  41. set -e
  42. rm -rf $PKG
  43. mkdir -p $TMP $PKG $OUTPUT
  44. cd $TMP
  45. rm -rf $SRCNAME
  46. unzip $CWD/$SRCNAME.zip
  47. cd $SRCNAME
  48. chown -R root:root .
  49. find -L . \
  50. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  51. -exec chmod 755 {} \; -o \
  52. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  53. -exec chmod 644 {} \;
  54. # Fix install destination of .pc file
  55. sed -i \
  56. -e 's:/lib/pkgconfig:/lib${LIB_SUFFIX}/pkgconfig:' \
  57. CMakeLists.txt
  58. mkdir -p build
  59. cd build
  60. cmake \
  61. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  62. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  63. -DCMAKE_INSTALL_PREFIX=/usr \
  64. -DLIB_SUFFIX=${LIBDIRSUFFIX} \
  65. -DMAN_INSTALL_DIR=/usr/man \
  66. -DCMAKE_BUILD_TYPE=Release ..
  67. make
  68. make install DESTDIR=$PKG
  69. cd ..
  70. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  71. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  72. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  73. cp -a \
  74. COPYING.txt README.txt \
  75. $PKG/usr/doc/$PRGNAM-$VERSION
  76. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  77. mkdir -p $PKG/install
  78. cat $CWD/slack-desc > $PKG/install/slack-desc
  79. cd $PKG
  80. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE