buildozer.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. [app]
  2. # (str) Title of your application
  3. title = Oui Wee
  4. # (str) Package name
  5. package.name = oui.wee
  6. # (str) Package domain (needed for android/ios packaging)
  7. #package.domain = https://notabug.org/2112/OuiWee
  8. # (str) Source code where the main.py live
  9. source.dir = .
  10. # (list) Source files to include (let empty to include all the files)
  11. source.include_exts = py,png,jpg,kv,atlas,ogg,gif
  12. # (list) Source files to exclude (let empty to not exclude anything)
  13. #source.exclude_exts = spec
  14. # (list) List of directory to exclude (let empty to not exclude anything)
  15. #source.exclude_dirs = tests, bin
  16. # (list) List of exclusions using pattern matching
  17. #source.exclude_patterns = license,images/*/*.jpg
  18. # (str) Application versioning (method 1)
  19. #version.regex = __version__ = ['"](.*)['"]
  20. #version.filename = %(source.dir)s/main.py
  21. #(str) Application versioning (method 2)
  22. version = 2.2.0
  23. # (list) Application requirements
  24. # comma seperated e.g. requirements = sqlite3,kivy
  25. requirements = kivy,pygame
  26. # (str) Custom source folders for requirements
  27. # Sets custom source for any requirements with recipes
  28. # requirements.source.kivy = ../../kivy
  29. # (list) Garden requirements
  30. #garden_requirements =
  31. # (str) Presplash of the application
  32. #presplash.filename = %(source.dir)s/titlewee.gif
  33. # (str) Icon of the application
  34. #icon.filename = %(source.dir)s/titlewee.gif
  35. # (str) Supported orientation (one of landscape, portrait or all)
  36. orientation = all
  37. # (bool) Indicate if the application should be fullscreen or not
  38. fullscreen = 1
  39. #
  40. # Android specific
  41. #
  42. # (list) Permissions
  43. #android.permissions = INTERNET
  44. # (int) Android API to use
  45. #android.api = 14
  46. # (int) Minimum API required (8 = Android 2.2 devices)
  47. #android.minapi = 8
  48. # (int) Android SDK version to use
  49. #android.sdk = 21
  50. # (str) Android NDK version to use
  51. #android.ndk = 9c
  52. # (bool) Use --private data storage (True) or --dir public storage (False)
  53. #android.private_storage = True
  54. # (str) Android NDK directory (if empty, it will be automatically downloaded.)
  55. #android.ndk_path =
  56. # (str) Android SDK directory (if empty, it will be automatically downloaded.)
  57. #android.sdk_path =
  58. # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
  59. #android.p4a_dir =
  60. # (list) python-for-android whitelist
  61. #android.p4a_whitelist =
  62. # (str) Android entry point, default is ok for Kivy-based app
  63. #android.entrypoint = org.renpy.android.PythonActivity
  64. # (list) List of Java .jar files to add to the libs so that pyjnius can access
  65. # their classes. Don't add jars that you do not need, since extra jars can slow
  66. # down the build process. Allows wildcards matching, for example:
  67. # OUYA-ODK/libs/*.jar
  68. #android.add_jars = foo.jar,bar.jar,path/to/more/*.jar
  69. # (list) List of Java files to add to the android project (can be java or a
  70. # directory containing the files)
  71. #android.add_src =
  72. # (str) python-for-android branch to use, if not master, useful to try
  73. # not yet merged features.
  74. #android.branch = master
  75. # (str) OUYA Console category. Should be one of GAME or APP
  76. # If you leave this blank, OUYA support will not be enabled
  77. #android.ouya.category = GAME
  78. # (str) Filename of OUYA Console icon. It must be a 732x412 png image.
  79. #android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png
  80. # (str) XML file to include as an intent filters in <activity> tag
  81. #android.manifest.intent_filters =
  82. # (list) Android additionnal libraries to copy into libs/armeabi
  83. #android.add_libs_armeabi = libs/android/*.so
  84. #android.add_libs_armeabi_v7a = libs/android-v7/*.so
  85. #android.add_libs_x86 = libs/android-x86/*.so
  86. #android.add_libs_mips = libs/android-mips/*.so
  87. # (bool) Indicate whether the screen should stay on
  88. # Don't forget to add the WAKE_LOCK permission if you set this to True
  89. #android.wakelock = False
  90. # (list) Android application meta-data to set (key=value format)
  91. #android.meta_data =
  92. # (list) Android library project to add (will be added in the
  93. # project.properties automatically.)
  94. #android.library_references =
  95. #
  96. # iOS specific
  97. #
  98. # (str) Name of the certificate to use for signing the debug version
  99. # Get a list of available identities: buildozer ios list_identities
  100. #ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)"
  101. # (str) Name of the certificate to use for signing the release version
  102. #ios.codesign.release = %(ios.codesign.debug)s
  103. [buildozer]
  104. # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
  105. log_level = 2 #switchedfromoneoriginallyimeanwasone
  106. # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
  107. warn_on_root = 1
  108. # -----------------------------------------------------------------------------
  109. # List as sections
  110. #
  111. # You can define all the "list" as [section:key].
  112. # Each line will be considered as a option to the list.
  113. # Let's take [app] / source.exclude_patterns.
  114. # Instead of doing:
  115. #
  116. #[app]
  117. #source.exclude_patterns = license,data/audio/*.wav,data/images/original/*
  118. #
  119. # This can be translated into:
  120. #
  121. #[app:source.exclude_patterns]
  122. #license
  123. #data/audio/*.wav
  124. #data/images/original/*
  125. #
  126. # -----------------------------------------------------------------------------
  127. # Profiles
  128. #
  129. # You can extend section / key with a profile
  130. # For example, you want to deploy a demo version of your application without
  131. # HD content. You could first change the title to add "(demo)" in the name
  132. # and extend the excluded directories to remove the HD content.
  133. #
  134. #[app@demo]
  135. #title = My Application (demo)
  136. #
  137. #[app:source.exclude_patterns@demo]
  138. #images/hd/*
  139. #
  140. # Then, invoke the command line with the "demo" profile:
  141. #
  142. #buildozer --profile demo android debug